summaryrefslogtreecommitdiff
path: root/nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-03 21:51:25 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-08 11:49:24 +0200
commit0c684b7edfacada4f576855dbb09291f04a84fa2 (patch)
treed4df94e7ae576b48d238bcccac315edf026277d5 /nix
parent2e3e5d21988fc2cafb2a9eaf4b00976ea425629d (diff)
downloadpatches-0c684b7edfacada4f576855dbb09291f04a84fa2.tar
patches-0c684b7edfacada4f576855dbb09291f04a84fa2.tar.gz
daemon: Run 'guix authenticate' directly.
* nix/scripts/authenticate.in: Remove. * nix/local.mk (nodist_pkglibexec_SCRIPTS): Remove scripts/authenticate. * config-daemon.ac: Don't output 'nix/scripts/authenticate'. * nix/libstore/local-store.cc (runAuthenticationProgram): Run 'guix authenticate'.
Diffstat (limited to 'nix')
-rw-r--r--nix/libstore/local-store.cc5
-rw-r--r--nix/local.mk3
-rw-r--r--nix/scripts/authenticate.in11
3 files changed, 3 insertions, 16 deletions
diff --git a/nix/libstore/local-store.cc b/nix/libstore/local-store.cc
index 892d9300b1..951c35faf3 100644
--- a/nix/libstore/local-store.cc
+++ b/nix/libstore/local-store.cc
@@ -1224,8 +1224,9 @@ static void checkSecrecy(const Path & path)
static std::string runAuthenticationProgram(const Strings & args)
{
- return runProgram(settings.nixLibexecDir + "/authenticate",
- false, args);
+ Strings fullArgs = { "authenticate" };
+ fullArgs.insert(fullArgs.end(), args.begin(), args.end()); // append
+ return runProgram(settings.guixProgram, false, fullArgs);
}
void LocalStore::exportPath(const Path & path, bool sign,
diff --git a/nix/local.mk b/nix/local.mk
index fd7379b5ff..cdcd9eb1c2 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -165,9 +165,6 @@ nodist_pkglibexec_SCRIPTS += \
endif BUILD_DAEMON_OFFLOAD
-nodist_pkglibexec_SCRIPTS += \
- %D%/scripts/authenticate
-
# The '.service' files for systemd.
systemdservicedir = $(libdir)/systemd/system
nodist_systemdservice_DATA = etc/guix-daemon.service etc/guix-publish.service
diff --git a/nix/scripts/authenticate.in b/nix/scripts/authenticate.in
deleted file mode 100644
index 5ce57915f0..0000000000
--- a/nix/scripts/authenticate.in
+++ /dev/null
@@ -1,11 +0,0 @@
-#!@SHELL@
-# A shorthand for "guix authenticate", for use by the daemon.
-
-if test "x$GUIX_UNINSTALLED" = "x"
-then
- prefix="@prefix@"
- exec_prefix="@exec_prefix@"
- exec "@bindir@/guix" authenticate "$@"
-else
- exec guix authenticate "$@"
-fi