summaryrefslogtreecommitdiff
path: root/nix/scripts
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-03 22:11:47 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-08 11:49:24 +0200
commitbc69ea2d605810cc32e13ed03d5848b8dc358b61 (patch)
treec4cbe1017a77ff853255d41b44301ff68c5257a1 /nix/scripts
parent9fcc35c51fd579b3bb7b4f61cba6973675c3922c (diff)
downloadpatches-bc69ea2d605810cc32e13ed03d5848b8dc358b61.tar
patches-bc69ea2d605810cc32e13ed03d5848b8dc358b61.tar.gz
daemon: Run 'guix offload' directly.
* nix/scripts/offload.in: Remove. * nix/local.mk (nodist_pkglibexec_SCRIPTS) [BUILD_DAEMON_OFFLOAD]: Remove 'scripts/offload'. * config-daemon.ac: Don't output 'nix/scripts/offload'. * build-aux/pre-inst-env.in: Don't set 'NIX_BUILD_HOOK'. * nix/libstore/build.cc (HookInstance::HookInstance): Run 'guix offload'. (DerivationGoal::tryBuildHook): Remove reference to 'NIX_BUILD_HOOK'. * nix/nix-daemon/guix-daemon.cc (main) [HAVE_DAEMON_OFFLOAD_HOOK]: Don't set 'NIX_BUILD_HOOK'. * nix/nix-daemon/nix-daemon.cc (performOp) [!HAVE_DAEMON_OFFLOAD_HOOK]: Leave 'settings.useBuildHook' unchanged.
Diffstat (limited to 'nix/scripts')
-rw-r--r--nix/scripts/offload.in11
1 files changed, 0 insertions, 11 deletions
diff --git a/nix/scripts/offload.in b/nix/scripts/offload.in
deleted file mode 100644
index 50faed31c0..0000000000
--- a/nix/scripts/offload.in
+++ /dev/null
@@ -1,11 +0,0 @@
-#!@SHELL@
-# A shorthand for "guix offload", for use by the daemon.
-
-if test "x$GUIX_UNINSTALLED" = "x"
-then
- prefix="@prefix@"
- exec_prefix="@exec_prefix@"
- exec "@bindir@/guix" offload "$@"
-else
- exec guix offload "$@"
-fi