summaryrefslogtreecommitdiff
path: root/nix/nix-daemon/shared.hh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-03 23:04:47 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-03 23:05:08 +0100
commitc2033df432af87d0176347858c7d11acfe2ed89f (patch)
tree05a7befd50cead52a401165c03dee3ae72840619 /nix/nix-daemon/shared.hh
parent7eba5e6361b637a4c8aecbb13644f573a845732b (diff)
downloadpatches-c2033df432af87d0176347858c7d11acfe2ed89f.tar
patches-c2033df432af87d0176347858c7d11acfe2ed89f.tar.gz
build: Include a copy of Nix's libstore and daemon; build it.
* configure.ac: Call `AC_USE_SYSTEM_EXTENSIONS', and `GUIX_SYSTEM_TYPE'. Add `--with-store-dir' option, and substitute `storedir'. Include `config-daemon.ac'. * config-daemon.ac: New file. * Makefile.am [BUILD_DAEMON]: Include `daemon.am'. * daemon.am: New file. * m4/guix.m4 (GUIX_SYSTEM_TYPE): New macro. * nix/libutil/gcrypt-hash.cc, nix/libutil/gcrypt-hash.hh, nix/libutil/md5.h, nix/libutil/sha1.h, nix/libutil/sha256.h, nix/nix-daemon/guix-daemon.cc, nix/nix-daemon/shared.hh: New files.
Diffstat (limited to 'nix/nix-daemon/shared.hh')
-rw-r--r--nix/nix-daemon/shared.hh37
1 files changed, 37 insertions, 0 deletions
diff --git a/nix/nix-daemon/shared.hh b/nix/nix-daemon/shared.hh
new file mode 100644
index 0000000000..a03c09c036
--- /dev/null
+++ b/nix/nix-daemon/shared.hh
@@ -0,0 +1,37 @@
+/* Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+ Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+
+ This file is part of Guix.
+
+ Guix is free software; you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or (at
+ your option) any later version.
+
+ Guix is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with Guix. If not, see <http://www.gnu.org/licenses/>. */
+
+/* Replacement for Nix's libmain/shared.hh. */
+
+#pragma once
+
+#include <string>
+
+#include <stdlib.h>
+#include <signal.h>
+
+static inline void
+showManPage (const char *name)
+{
+ /* This idea is evil. Abort. */
+ abort ();
+}
+
+extern volatile ::sig_atomic_t blockInt;
+
+extern char **argvSaved;