aboutsummaryrefslogtreecommitdiff
path: root/nix/local.mk
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-29 22:51:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-29 22:51:23 +0200
commitf1728d43460e63b106dd446e70001d8e100eaf6d (patch)
tree9d211fabf9e200743be49e25d108d58ed88d2f60 /nix/local.mk
parentcda7f4bc8ecf331d623c7d37b01931a46830c648 (diff)
parent373cc3b74a6ad33fddf75c2d773a97b1775bda8e (diff)
downloadpatches-f1728d43460e63b106dd446e70001d8e100eaf6d.tar
patches-f1728d43460e63b106dd446e70001d8e100eaf6d.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'nix/local.mk')
-rw-r--r--nix/local.mk21
1 files changed, 2 insertions, 19 deletions
diff --git a/nix/local.mk b/nix/local.mk
index 4452301c63..7d45f200b8 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -22,7 +22,7 @@
#
BUILT_SOURCES += %D%/libstore/schema.sql.hh
-CLEANFILES += $(BUILT_SOURCES)
+CLEANFILES += %D%/libstore/schema.sql.hh
noinst_LIBRARIES = libformat.a libutil.a libstore.a
@@ -120,7 +120,6 @@ libstore_a_CXXFLAGS = $(AM_CXXFLAGS) \
$(SQLITE3_CFLAGS) $(LIBGCRYPT_CFLAGS)
bin_PROGRAMS = guix-daemon
-sbin_PROGRAMS = guix-register
guix_daemon_SOURCES = \
%D%/nix-daemon/nix-daemon.cc \
@@ -138,24 +137,9 @@ guix_daemon_LDADD = \
guix_daemon_headers = \
%D%/nix-daemon/shared.hh
-
-guix_register_SOURCES = \
- %D%/guix-register/guix-register.cc
-
-guix_register_CPPFLAGS = \
- $(libutil_a_CPPFLAGS) \
- $(libstore_a_CPPFLAGS) \
- -I$(top_srcdir)/%D%/libstore
-
-# XXX: Should we start using shared libs?
-guix_register_LDADD = \
- libstore.a libutil.a libformat.a -lz \
- $(SQLITE3_LIBS) $(LIBGCRYPT_LIBS)
-
if HAVE_LIBBZ2
guix_daemon_LDADD += -lbz2
-guix_register_LDADD += -lbz2
endif HAVE_LIBBZ2
@@ -163,7 +147,7 @@ noinst_HEADERS = \
$(libformat_headers) $(libutil_headers) $(libstore_headers) \
$(guix_daemon_headers)
-%D%/libstore/schema.sql.hh: %D%/libstore/schema.sql
+%D%/libstore/schema.sql.hh: guix/store/schema.sql
$(AM_V_GEN)$(GUILE) --no-auto-compile -c \
"(use-modules (rnrs io ports)) \
(call-with-output-file \"$@\" \
@@ -216,7 +200,6 @@ CLEANFILES += \
$(nodist_upstartjob_DATA)
EXTRA_DIST += \
- %D%/libstore/schema.sql \
%D%/AUTHORS \
%D%/COPYING \
etc/guix-daemon.service.in \