summaryrefslogtreecommitdiff
path: root/nix/local.mk
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-11-30 18:24:32 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-11-30 18:24:32 +0100
commit8a7cbc882a75d7f9f1fe960552dea47acf347b0a (patch)
treeded8c9116d357b38fd23b8c0cc312863fe68c9b5 /nix/local.mk
parent3084a9908434e4e7123d2fd3881c798977abedb9 (diff)
parent72f0c5ea3c0272a93436ad3c04a281d1237a9593 (diff)
downloadpatches-8a7cbc882a75d7f9f1fe960552dea47acf347b0a.tar
patches-8a7cbc882a75d7f9f1fe960552dea47acf347b0a.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'nix/local.mk')
-rw-r--r--nix/local.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/nix/local.mk b/nix/local.mk
index 86ef769549..79667ed49e 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -183,26 +183,26 @@ endif BUILD_DAEMON_OFFLOAD
nodist_libexec_SCRIPTS = \
%D%/scripts/guix-authenticate
-# The '.service' file for systemd.
+# The '.service' files for systemd.
systemdservicedir = $(libdir)/systemd/system
-nodist_systemdservice_DATA = etc/guix-daemon.service
+nodist_systemdservice_DATA = etc/guix-daemon.service etc/guix-publish.service
-etc/guix-daemon.service: etc/guix-daemon.service.in \
+etc/guix-%.service: etc/guix-%.service.in \
$(top_builddir)/config.status
$(AM_V_GEN)$(MKDIR_P) "`dirname $@`"; \
$(SED) -e 's|@''bindir''@|$(bindir)|' < \
- "$(srcdir)/etc/guix-daemon.service.in" > "$@.tmp"; \
+ "$(srcdir)/$<" > "$@.tmp"; \
mv "$@.tmp" "$@"
-# The '.conf' job for Upstart.
+# The '.conf' jobs for Upstart.
upstartjobdir = $(libdir)/upstart/system
-nodist_upstartjob_DATA = etc/guix-daemon.conf
+nodist_upstartjob_DATA = etc/guix-daemon.conf etc/guix-publish.conf
-etc/guix-daemon.conf: etc/guix-daemon.conf.in \
+etc/guix-%.conf: etc/guix-%.conf.in \
$(top_builddir)/config.status
$(AM_V_GEN)$(MKDIR_P) "`dirname $@`"; \
$(SED) -e 's|@''bindir''@|$(bindir)|' < \
- "$(srcdir)/etc/guix-daemon.conf.in" > "$@.tmp"; \
+ "$(srcdir)/$<" > "$@.tmp"; \
mv "$@.tmp" "$@"
EXTRA_DIST += \