summaryrefslogtreecommitdiff
path: root/nix/libstore
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-03 21:51:25 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-08 11:49:24 +0200
commit0c684b7edfacada4f576855dbb09291f04a84fa2 (patch)
treed4df94e7ae576b48d238bcccac315edf026277d5 /nix/libstore
parent2e3e5d21988fc2cafb2a9eaf4b00976ea425629d (diff)
downloadpatches-0c684b7edfacada4f576855dbb09291f04a84fa2.tar
patches-0c684b7edfacada4f576855dbb09291f04a84fa2.tar.gz
daemon: Run 'guix authenticate' directly.
* nix/scripts/authenticate.in: Remove. * nix/local.mk (nodist_pkglibexec_SCRIPTS): Remove scripts/authenticate. * config-daemon.ac: Don't output 'nix/scripts/authenticate'. * nix/libstore/local-store.cc (runAuthenticationProgram): Run 'guix authenticate'.
Diffstat (limited to 'nix/libstore')
-rw-r--r--nix/libstore/local-store.cc5
1 files changed, 3 insertions, 2 deletions
diff --git a/nix/libstore/local-store.cc b/nix/libstore/local-store.cc
index 892d9300b1..951c35faf3 100644
--- a/nix/libstore/local-store.cc
+++ b/nix/libstore/local-store.cc
@@ -1224,8 +1224,9 @@ static void checkSecrecy(const Path & path)
static std::string runAuthenticationProgram(const Strings & args)
{
- return runProgram(settings.nixLibexecDir + "/authenticate",
- false, args);
+ Strings fullArgs = { "authenticate" };
+ fullArgs.insert(fullArgs.end(), args.begin(), args.end()); // append
+ return runProgram(settings.guixProgram, false, fullArgs);
}
void LocalStore::exportPath(const Path & path, bool sign,