summaryrefslogtreecommitdiff
path: root/nix/libstore/local-store.cc
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-02-04 16:14:09 +0100
committerLudovic Courtès <ludo@gnu.org>2019-02-04 16:20:01 +0100
commit959eaa1eb834fd47ceab3c5bbbe4967e808d530b (patch)
tree11af589b50530f3cdd09c895077a203e332464b9 /nix/libstore/local-store.cc
parent4d4a38f620520acc787ff5db2be3736923e14235 (diff)
downloadpatches-959eaa1eb834fd47ceab3c5bbbe4967e808d530b.tar
patches-959eaa1eb834fd47ceab3c5bbbe4967e808d530b.tar.gz
daemon: Add "/guix" to default 'nixLibexecDir'.
This makes it easier to run the uninstalled daemon. * nix/local.mk (libstore_a_CPPFLAGS): Append "/guix" to NIX_LIBEXEC_DIR. * build-aux/pre-inst-env.in (NIX_LIBEXEC_DIR): Adjust comment. * nix/libstore/builtins.cc (builtinDownload): Remove SUBDIR and its use. * nix/libstore/local-store.cc (runAuthenticationProgram): Ditto. * nix/libstore/gc.cc (addAdditionalRoots): Remove "/guix" prefix. * nix/nix-daemon/guix-daemon.cc (main): Ditto.
Diffstat (limited to 'nix/libstore/local-store.cc')
-rw-r--r--nix/libstore/local-store.cc10
1 files changed, 2 insertions, 8 deletions
diff --git a/nix/libstore/local-store.cc b/nix/libstore/local-store.cc
index eb8a51cc23..892d9300b1 100644
--- a/nix/libstore/local-store.cc
+++ b/nix/libstore/local-store.cc
@@ -1224,14 +1224,8 @@ static void checkSecrecy(const Path & path)
static std::string runAuthenticationProgram(const Strings & args)
{
- /* Use the 'authenticate' script from 'LIBEXECDIR/guix' or just
- 'LIBEXECDIR', depending on whether we're uninstalled or not. */
- const bool installed = getenv("GUIX_UNINSTALLED") == NULL;
- const string program = settings.nixLibexecDir
- + (installed ? "/guix" : "")
- + "/authenticate";
-
- return runProgram(program, false, args);
+ return runProgram(settings.nixLibexecDir + "/authenticate",
+ false, args);
}
void LocalStore::exportPath(const Path & path, bool sign,