summaryrefslogtreecommitdiff
path: root/hydra.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-29 21:44:31 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-29 21:44:31 +0100
commit4928e50033615e1d130dd84f131eff4cbc702ccf (patch)
tree320ff9bae85de20b0293119653b07b1197eaaa82 /hydra.scm
parent14a3a67364f46b24d7e39d64ac92879c3eb7f8eb (diff)
parent3f5a932eeaa8111b841de64b742b1cc408f2419a (diff)
downloadpatches-4928e50033615e1d130dd84f131eff4cbc702ccf.tar
patches-4928e50033615e1d130dd84f131eff4cbc702ccf.tar.gz
Merge branch 'master' into core-updates
Conflicts: Makefile.am gnu/packages/base.scm
Diffstat (limited to 'hydra.scm')
-rw-r--r--hydra.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/hydra.scm b/hydra.scm
index 8e3be16b08..8cbfecf34c 100644
--- a/hydra.scm
+++ b/hydra.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +21,21 @@
;;; tool.
;;;
+;; Attempt to use our very own Guix modules.
+(eval-when (compile load eval)
+
+ ;; Ignore any available .go, and force recompilation. This is because our
+ ;; checkout in the store has mtime set to the epoch, and thus .go files look
+ ;; newer, even though they may not correspond.
+ (set! %fresh-auto-compile #t)
+
+ (and=> (assoc-ref (current-source-location) 'filename)
+ (lambda (file)
+ (let ((dir (dirname file)))
+ (format (current-error-port) "prepending ~s to the load path~%"
+ dir)
+ (set! %load-path (cons dir %load-path))))))
+
(use-modules (guix store)
(guix packages)
((guix utils) #:select (%current-system))