summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-27 09:17:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-27 18:39:10 +0200
commit61b95c15cfb2c9b0d02cf09f93c0df76be0972b5 (patch)
tree41b29d381339a99aa68c6485790560abe6e13b20 /guix
parentd0c4d1abfe54c12a0dfa467267859802f65c3bbc (diff)
downloadpatches-61b95c15cfb2c9b0d02cf09f93c0df76be0972b5.tar
patches-61b95c15cfb2c9b0d02cf09f93c0df76be0972b5.tar.gz
build: cargo-build-system: Add pkg-config environment variables.
* guix/build/cargo-build-system.scm (configure): Add environment variables to use system libgit2 and libssh2. * gnu/packages/crates-io.scm (rust-libgit2-sys-0.10, rust-libssh2-sys-0.2)[arguments]: Remove LIBGIT2 and LIBSSH2 environment variable settings. * gnu/packages/rust-apps.scm (tokei)[arguments]: Same.
Diffstat (limited to 'guix')
-rw-r--r--guix/build/cargo-build-system.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/guix/build/cargo-build-system.scm b/guix/build/cargo-build-system.scm
index 78c27a29e4..0721989589 100644
--- a/guix/build/cargo-build-system.scm
+++ b/guix/build/cargo-build-system.scm
@@ -119,6 +119,8 @@ directory = '" port)
;; upgrading the compiler for example.
(setenv "RUSTFLAGS" "--cap-lints allow")
(setenv "CC" (string-append (assoc-ref inputs "gcc") "/bin/gcc"))
+ (setenv "LIBGIT2_SYS_USE_PKG_CONFIG" "1")
+ (setenv "LIBSSH2_SYS_USE_PKG_CONFIG" "1")
;; We don't use the Cargo.lock file to determine the package versions we use
;; during building, and in any case if one is not present it is created