summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-13 15:05:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-13 15:20:16 +0300
commit43ffa11fdc4de4197a1096f6ebc4067115f9eb26 (patch)
tree4567355b376323ee57589311b33a1d856e20ce2a /guix
parentf69f37d54a677c1816b225ead7503a4e3cfee24d (diff)
downloadpatches-43ffa11fdc4de4197a1096f6ebc4067115f9eb26.tar
patches-43ffa11fdc4de4197a1096f6ebc4067115f9eb26.tar.gz
build-system/cargo: Use 'strip-store-file-name'.
This is a follow-up to f58b2f38e4dfdbb8473fb2816d44fae6ad9cbc79. * guix/build/cargo-build-system.scm (configure): Use bespoke 'strip-store-file-name' function.
Diffstat (limited to 'guix')
-rw-r--r--guix/build/cargo-build-system.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build/cargo-build-system.scm b/guix/build/cargo-build-system.scm
index 0134997c27..c69cae5afd 100644
--- a/guix/build/cargo-build-system.scm
+++ b/guix/build/cargo-build-system.scm
@@ -99,7 +99,7 @@ Cargo.toml file present at its root."
(for-each
(match-lambda
((name . path)
- (let* ((basepath (string-drop (basename path) 33))
+ (let* ((basepath (strip-store-file-name path))
(crate-dir (string-append vendor-dir "/" basepath)))
(and (crate-src? path)
;; Gracefully handle duplicate inputs