summaryrefslogtreecommitdiff
path: root/guix/upstream.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-03-09 15:08:00 +0100
committerLudovic Courtès <ludo@gnu.org>2016-03-09 15:08:00 +0100
commitf1eacbafc4b98b8665856640c9d728372857eebf (patch)
treea32c7b47678d4f7b23b224762f1fdb101a381a03 /guix/upstream.scm
parent1ddee42472ecdad3d2dbbc2482aab5e3add3abdd (diff)
downloadpatches-f1eacbafc4b98b8665856640c9d728372857eebf.tar
patches-f1eacbafc4b98b8665856640c9d728372857eebf.tar.gz
upstream: Fix 'signature-urls' coalescing.
Previously, the resulting 'signature-urls' would contain N times the same URL. * guix/upstream.scm (coalesce-sources): Fix TWO in 'signature-urls'. * tests/upstream.scm: New file. * Makefile.am (SCM_TESTS): Add it.
Diffstat (limited to 'guix/upstream.scm')
-rw-r--r--guix/upstream.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/upstream.scm b/guix/upstream.scm
index c62667dd01..cea23feb82 100644
--- a/guix/upstream.scm
+++ b/guix/upstream.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2010, 2011, 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2010, 2011, 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -99,7 +99,7 @@ correspond to the same version."
(upstream-source-urls head)))
(signature-urls
(let ((one (upstream-source-signature-urls release))
- (two (upstream-source-signature-urls release)))
+ (two (upstream-source-signature-urls head)))
(and one two (append one two)))))
tail)
(cons release result)))