summaryrefslogtreecommitdiff
path: root/guix/packages.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-26 10:22:15 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-26 10:26:02 +0100
commite6301fb76d0a8d931ece2e18d197e3c2cc53fc6c (patch)
tree481d8ff64542c7bc1498c208e2faa01464ba0b27 /guix/packages.scm
parent6c177f6140cba250ad68c5a83c312f395b6e48b4 (diff)
downloadpatches-e6301fb76d0a8d931ece2e18d197e3c2cc53fc6c.tar
patches-e6301fb76d0a8d931ece2e18d197e3c2cc53fc6c.tar.gz
packages: Adjust to new calling convention for "thunked" fields.
Fixes <https://bugs.gnu.org/34995>. This is a followup to abd4d6b33dba4de228e90ad15a8efb456fcf7b6e. * guix/packages.scm (package->bag): Adjust calls to INPUTS, PROPAGATED-INPUTS, NATIVE-INPUTS, and ARGS, passing them SELF as an argument. * gnu/packages/gnucash.scm (gnucash)[arguments]: Use (package-inputs this-record) intead of (inputs). * gnu/packages/version-control.scm (git)[arguments]: Likewise.
Diffstat (limited to 'guix/packages.scm')
-rw-r--r--guix/packages.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/guix/packages.scm b/guix/packages.scm
index d20a2562c3..9d83de3d48 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -1025,9 +1025,10 @@ and return it."
(match (if graft?
(or (package-replacement package) package)
package)
- (($ <package> name version source build-system
- args inputs propagated-inputs native-inputs
- self-native-input? outputs)
+ ((and self
+ ($ <package> name version source build-system
+ args inputs propagated-inputs native-inputs
+ self-native-input? outputs))
;; Even though we prefer to use "@" to separate the package
;; name from the package version in various user-facing parts
;; of Guix, checkStoreName (in nix/libstore/store-api.cc)
@@ -1036,15 +1037,15 @@ and return it."
#:system system
#:target target
#:source source
- #:inputs (append (inputs)
- (propagated-inputs))
+ #:inputs (append (inputs self)
+ (propagated-inputs self))
#:outputs outputs
#:native-inputs `(,@(if (and target
self-native-input?)
- `(("self" ,package))
+ `(("self" ,self))
'())
- ,@(native-inputs))
- #:arguments (args))
+ ,@(native-inputs self))
+ #:arguments (args self))
(raise (if target
(condition
(&package-cross-build-system-error