summaryrefslogtreecommitdiff
path: root/guix/import/elpa.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-28 17:12:20 +0200
committerLudovic Courtès <ludo@gnu.org>2017-03-28 22:15:44 +0200
commite1f02f92e90dac57431c3a0c557162fe1d5e9192 (patch)
tree85a302a19964e4070e90684bf7828034dadd7a9d /guix/import/elpa.scm
parent23b9168dcdb0bdd47f74a81dc9653e1e05142a14 (diff)
downloadpatches-e1f02f92e90dac57431c3a0c557162fe1d5e9192.tar
patches-e1f02f92e90dac57431c3a0c557162fe1d5e9192.tar.gz
Replace (compose not PROC) with simpler idioms.
* gnu/packages/bioinformatics.scm (python-pysam)[arguments] <check>: Use (negate proc) instead of (compose not proc). * guix/import/cran.scm (recursive-import): Likewise. * guix/import/elpa.scm (filter-dependencies): Use 'remove' instead of '(filter (compose not proc) ...)'.
Diffstat (limited to 'guix/import/elpa.scm')
-rw-r--r--guix/import/elpa.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/import/elpa.scm b/guix/import/elpa.scm
index c0b0c415cf..b1003304d0 100644
--- a/guix/import/elpa.scm
+++ b/guix/import/elpa.scm
@@ -57,7 +57,7 @@ past were distributed separately from Emacs."
(define (filter-dependencies names)
"Remove the package names included with Emacs from the list of
NAMES (strings)."
- (filter (compose not emacs-standard-library?) names))
+ (remove emacs-standard-library? names))
(define (elpa-name->package-name name)
"Given the NAME of an Emacs package, return the corresponding Guix name."