summaryrefslogtreecommitdiff
path: root/guix/build/minify-build-system.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-02 22:49:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-04 11:23:52 +0200
commit88c8f247e594239807aafe80d5e8b084d07e32f6 (patch)
treec854d26b3d2d3d287230699fca10b698d6217e0b /guix/build/minify-build-system.scm
parentb316caaa9cda8bf2a8b20d5ba87b5d306f3b39bd (diff)
downloadpatches-88c8f247e594239807aafe80d5e8b084d07e32f6.tar
patches-88c8f247e594239807aafe80d5e8b084d07e32f6.tar.gz
build: Add minify build system.
* guix/build-system/minify.scm: New file. * guix/build/minify-build-system: New file. * Makefile.am (MODULES): Add new files. * doc/guix.texi (Build Systems): Document minify-build-system.
Diffstat (limited to 'guix/build/minify-build-system.scm')
-rw-r--r--guix/build/minify-build-system.scm73
1 files changed, 73 insertions, 0 deletions
diff --git a/guix/build/minify-build-system.scm b/guix/build/minify-build-system.scm
new file mode 100644
index 0000000000..3580deda07
--- /dev/null
+++ b/guix/build/minify-build-system.scm
@@ -0,0 +1,73 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build minify-build-system)
+ #:use-module ((guix build gnu-build-system) #:prefix gnu:)
+ #:use-module ((guix build minify-build-system) #:prefix minify:)
+ #:use-module (guix build utils)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26)
+ #:use-module (ice-9 popen)
+ #:export (%standard-phases
+ minify-build
+ minify))
+
+;; Commentary:
+;;
+;; Builder-side code of the standard minification procedure for JavaScript
+;; files.
+;;
+;; Code:
+
+(define* (minify file #:key target (directory ""))
+ (format #t "minifying ~a\n" file)
+ (let* ((base (basename file ".js"))
+ (installed (or target (string-append directory base ".min.js")))
+ (minified (open-pipe* OPEN_READ "uglify-js" file)))
+ (call-with-output-file installed
+ (cut dump-port minified <>))
+ #t))
+
+(define* (build #:key javascript-files
+ #:allow-other-keys)
+ (let ((files (or javascript-files
+ (find-files "src" "\\.js$"))))
+ (mkdir-p "guix/build")
+ (every (cut minify <> #:directory "guix/build/") files)))
+
+(define* (install #:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (js (string-append out "/share/javascript/")))
+ (mkdir-p js)
+ (for-each (cut install-file <> js)
+ (find-files "guix/build" "\\.min\\.js$")))
+ #t)
+
+(define %standard-phases
+ (modify-phases gnu:%standard-phases
+ (delete 'configure)
+ (replace 'build build)
+ (delete 'check)
+ (replace 'install install)))
+
+(define* (minify-build #:key inputs (phases %standard-phases)
+ #:allow-other-keys #:rest args)
+ "Build the given JavaScript package, applying all of PHASES in order."
+ (apply gnu:gnu-build #:inputs inputs #:phases phases args))
+
+;;; minify-build-system.scm ends here