summaryrefslogtreecommitdiff
path: root/guix/build/cargo-build-system.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-12 20:20:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-12 20:22:46 +0300
commitf58b2f38e4dfdbb8473fb2816d44fae6ad9cbc79 (patch)
tree2a0de031a93b9a6c512b7f4795b2d919c3ba0983 /guix/build/cargo-build-system.scm
parentabed5df7774a637a0104ca05254e8f97226d38d5 (diff)
downloadpatches-f58b2f38e4dfdbb8473fb2816d44fae6ad9cbc79.tar
patches-f58b2f38e4dfdbb8473fb2816d44fae6ad9cbc79.tar.gz
build: cargo-build-system: Strip store hash from vendor-dir.
* guix/build/cargo-build-system.scm (configure): When copying the sources into the vendor-dir strip off the hash before the package name.
Diffstat (limited to 'guix/build/cargo-build-system.scm')
-rw-r--r--guix/build/cargo-build-system.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build/cargo-build-system.scm b/guix/build/cargo-build-system.scm
index f173b64c83..0134997c27 100644
--- a/guix/build/cargo-build-system.scm
+++ b/guix/build/cargo-build-system.scm
@@ -99,7 +99,7 @@ Cargo.toml file present at its root."
(for-each
(match-lambda
((name . path)
- (let* ((basepath (basename path))
+ (let* ((basepath (string-drop (basename path) 33))
(crate-dir (string-append vendor-dir "/" basepath)))
(and (crate-src? path)
;; Gracefully handle duplicate inputs