summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-22 20:31:40 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-23 15:43:08 +0100
commitfce8ec9e1514a25f3698553449635a2fe5d80811 (patch)
treefd4403720bc567569ae4b748882aa351421bc984 /guix/build-system
parent867383efbc1bfaaaec992d748939acc71203fbc1 (diff)
downloadpatches-fce8ec9e1514a25f3698553449635a2fe5d80811.tar
patches-fce8ec9e1514a25f3698553449635a2fe5d80811.tar.gz
build-system: qt: Actually use qt-build-system, not cmake-build-system.
When the qt-build-system was created, based on the cmake-build-system, some references to cmake have been missed to be changed. * guix/build-system/qt.scm (qt-build, qt-cross-build)[modules]: Use qt-build-system, not cmake-build-system. [builder]: Call qt-build, not cmake-build. Coauthored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/qt.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/guix/build-system/qt.scm b/guix/build-system/qt.scm
index b776845377..67fdfa1230 100644
--- a/guix/build-system/qt.scm
+++ b/guix/build-system/qt.scm
@@ -126,14 +126,14 @@
(qt-wrap-excluded-outputs ''())
(system (%current-system))
(imported-modules %qt-build-system-modules)
- (modules '((guix build cmake-build-system)
+ (modules '((guix build qt-build-system)
(guix build utils))))
"Build SOURCE using CMAKE, and with INPUTS. This assumes that SOURCE
provides a 'CMakeLists.txt' file as its build system."
(define builder
`(begin
(use-modules ,@modules)
- (cmake-build #:source ,(match (assoc-ref inputs "source")
+ (qt-build #:source ,(match (assoc-ref inputs "source")
(((? derivation? source))
(derivation->output-path source))
((source)
@@ -208,7 +208,7 @@ provides a 'CMakeLists.txt' file as its build system."
(system (%current-system))
(build (nix-system->gnu-triplet system))
(imported-modules %qt-build-system-modules)
- (modules '((guix build cmake-build-system)
+ (modules '((guix build qt-build-system)
(guix build utils))))
"Cross-build NAME using CMAKE for TARGET, where TARGET is a GNU triplet and
with INPUTS. This assumes that SOURCE provides a 'CMakeLists.txt' file as its
@@ -237,7 +237,7 @@ build system."
`(,name . ,path)))
target-drvs))
- (cmake-build #:source ,(match (assoc-ref native-drvs "source")
+ (qt-build #:source ,(match (assoc-ref native-drvs "source")
(((? derivation? source))
(derivation->output-path source))
((source)