summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-07-14 14:50:21 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-07-14 14:57:46 +0200
commit8eb0ba532ebbebef23180e666e0607ea735f9c1a (patch)
treeba31760fdf7777274dae2e6b63b3c6ec05ab90ee /guix/build-system
parent09a1f92f61d1ab11d2cf9f7a0983f4fc9f436f57 (diff)
downloadpatches-8eb0ba532ebbebef23180e666e0607ea735f9c1a.tar
patches-8eb0ba532ebbebef23180e666e0607ea735f9c1a.tar.gz
guix: node-build-system: Use guile-json instead of a custom parser.
* guix/build/json.scm: Remove file. * Makefile.am: Remove it. * guix/build/node-build-system.scm: Use (json parser) instead of (guix build json). * guix/build-system/node.scm: Idem.
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/node.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/guix/build-system/node.scm b/guix/build-system/node.scm
index 05c24c47d5..dad492dc95 100644
--- a/guix/build-system/node.scm
+++ b/guix/build-system/node.scm
@@ -18,7 +18,6 @@
(define-module (guix build-system node)
#:use-module (guix store)
- #:use-module (guix build json)
#:use-module (guix build union)
#:use-module (guix utils)
#:use-module (guix packages)
@@ -27,6 +26,7 @@
#:use-module (guix build-system)
#:use-module (guix build-system gnu)
#:use-module (ice-9 match)
+ #:use-module (json parser)
#:export (npm-meta-uri
%node-build-system-modules
node-build
@@ -40,8 +40,8 @@ registry."
(define %node-build-system-modules
;; Build-side modules imported by default.
`((guix build node-build-system)
- (guix build json)
(guix build union)
+ (json parser)
,@%gnu-build-system-modules)) ;; TODO: Might be not needed
(define (default-node)
@@ -88,9 +88,9 @@ registry."
(guile #f)
(imported-modules %node-build-system-modules)
(modules '((guix build node-build-system)
- (guix build json)
- (guix build union)
- (guix build utils))))
+ (guix build union)
+ (guix build utils)
+ (json parser))))
"Build SOURCE using NODE and INPUTS."
(define builder
`(begin