summaryrefslogtreecommitdiff
path: root/guix/build-system/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2020-02-22 09:56:36 -0500
committerGuix Patches Tester <>2020-02-22 15:36:13 +0000
commit7a1f5ef1822a80ec7b6edc57921cd7f6837bb237 (patch)
treeb44a1e0daa0cfff0a7baf727e7d027f04ef81ab9 /guix/build-system/haskell.scm
parent9a3971143854bf877c0739fc8fdf7b945a2e3935 (diff)
downloadpatches-7a1f5ef1822a80ec7b6edc57921cd7f6837bb237.tar
patches-7a1f5ef1822a80ec7b6edc57921cd7f6837bb237.tar.gz
build-system/haskell: Add 'extra-directories?' keyword.series-2978
See <https://bugs.gnu.org/39309>. * guix/build-system/haskell.scm (haskell-build): Add 'extra-directories?' keyword and pass it through to the builder. * guix/build/haskell-build-system.scm (configure): Use it to toggle passing 'extra-include-dirs' and 'extra-lib-dirs' to Cabal. * gnu/packages/haskell-xyz.scm (ghc-alsa-core, ghc-hmatrix, ghc-hmatrix-gsl, ghc-hslua, ghc-iwlib, ghc-libyaml, ghc-ncurses, ghc-openglraw, ghc-x11, ghc-x11-xft, ghc-zlib): Enable 'extra-directories?'. gnu/packages/haskell-crypto.scm (ghc-digest, ghc-hsopenssl): Likewise.
Diffstat (limited to 'guix/build-system/haskell.scm')
-rw-r--r--guix/build-system/haskell.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/guix/build-system/haskell.scm b/guix/build-system/haskell.scm
index 1ec11c71d8..25f4797d16 100644
--- a/guix/build-system/haskell.scm
+++ b/guix/build-system/haskell.scm
@@ -106,6 +106,7 @@ version REVISION."
(tests? #t)
(test-target "test")
(configure-flags ''())
+ extra-directories?
(phases '(@ (guix build haskell-build-system)
%standard-phases))
(outputs '("out"))
@@ -134,6 +135,7 @@ provides a 'Setup.hs' file as its build system."
(derivation->output-path revision))
(revision revision))
#:configure-flags ,configure-flags
+ #:extra-directories? ,extra-directories?
#:haddock-flags ,haddock-flags
#:system ,system
#:test-target ,test-target