summaryrefslogtreecommitdiff
path: root/guix/build-system/cmake.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-16 14:05:00 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-16 14:05:00 +0200
commit35ac56b63e438aaefde9364db7164dd213677022 (patch)
treea3e3fdf6abdff1740a4801b987a2c212c928469c /guix/build-system/cmake.scm
parent50efa797742af747f8d544a4fac52116993d9da8 (diff)
downloadpatches-35ac56b63e438aaefde9364db7164dd213677022.tar
patches-35ac56b63e438aaefde9364db7164dd213677022.tar.gz
build-system/{perl,cmake}: Keep the standard search paths of gnu-build-system.
Reported by Andreas Enge <andreas@enge.fr>. * guix/build-system/gnu.scm (standard-search-paths): New procedure. (gnu-build): Use it. * guix/build-system/perl.scm (perl-build): Append (standard-search-paths) to the search paths of PERL. * guix/build-system/cmake.scm (cmake-build): Append (standard-search-paths) to SEARCH-PATHS.
Diffstat (limited to 'guix/build-system/cmake.scm')
-rw-r--r--guix/build-system/cmake.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 4e993f3961..3347dc502c 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -72,7 +72,8 @@ provides a 'CMakeLists.txt' file as its build system."
#:outputs %outputs
#:inputs %build-inputs
#:search-paths ',(map search-path-specification->sexp
- search-paths)
+ (append search-paths
+ (standard-search-paths)))
#:patches ,patches
#:patch-flags ,patch-flags
#:phases ,phases