summaryrefslogtreecommitdiff
path: root/guix/build-system/ant.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-06-13 00:10:01 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-06-20 18:10:35 +0530
commit148585c240f848ad08f6541ede7db3fca3411007 (patch)
tree888fb2606c8ef9c9b3371bc390704d185ed606d0 /guix/build-system/ant.scm
parent2e701cd3841d4449b3963d4337c543be99ed7bcc (diff)
downloadpatches-148585c240f848ad08f6541ede7db3fca3411007.tar
patches-148585c240f848ad08f6541ede7db3fca3411007.tar.gz
gnu: Move contents of zip module into compression module.
* gnu/packages/zip.scm (zip, unzip, zziplib, perl-zip): Move to... * gnu/packages/compression.scm: ...here. * gnu/packages/zip.scm: Delete file. * gnu/local.mk (GNU_SYSTEM_MODULES): Unregister deleted file. * po/packages/POTFILES.in: Unregister deleted file. * gnu/packages/{audio, avr, bioinformatics, busybox, cdrom, ci, compression, docbook, documentation, fonts, fpga, game-development, games, gl, gnome, gnuzilla, graphics, guile, haskell, image, java, kodi, ldc, libreoffice, markup, maths, mc, monitoring, music, php, pretty-print, python, scheme, smalltalk, statistics, synergy, tex, textutils, video, web-browsers, xml, zip}.scm, guix/build-system/{ant, font}.scm, guix/{download, packages}.scm: Adapt module import.
Diffstat (limited to 'guix/build-system/ant.scm')
-rw-r--r--guix/build-system/ant.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build-system/ant.scm b/guix/build-system/ant.scm
index 228b4e60d2..e0870a605c 100644
--- a/guix/build-system/ant.scm
+++ b/guix/build-system/ant.scm
@@ -58,7 +58,7 @@
(define (default-zip)
"Return the default ZIP package."
;; Lazily resolve the binding to avoid a circular dependency.
- (let ((zip-mod (resolve-interface '(gnu packages zip))))
+ (let ((zip-mod (resolve-interface '(gnu packages compression))))
(module-ref zip-mod 'zip)))
(define* (lower name