summaryrefslogtreecommitdiff
path: root/guix-download.in
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-01 00:50:01 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-01 00:52:44 +0100
commit073c34d72f94adf6c4c307239b1de0d14bdb60f3 (patch)
treeb671d6032f3feb08513d80c1be4870053b5af671 /guix-download.in
parent111111d04662bb9056c8b56d11e634dc4506ee1e (diff)
downloadpatches-073c34d72f94adf6c4c307239b1de0d14bdb60f3.tar
patches-073c34d72f94adf6c4c307239b1de0d14bdb60f3.tar.gz
Add (guix ui).
* guix/ui.scm: New file. * Makefile.am (MODULES): Add it. * po/POTFILES.in: Add it. * guix-build.in: Use it. (_, N_, leave): Remove. (guix-build): Use `with-error-handling' instead of the `guard' form. * guix-download.in: Use it. (_, N_, leave): Remove.
Diffstat (limited to 'guix-download.in')
-rw-r--r--guix-download.in10
1 files changed, 1 insertions, 9 deletions
diff --git a/guix-download.in b/guix-download.in
index 3892b2efe3..b574c962b4 100644
--- a/guix-download.in
+++ b/guix-download.in
@@ -32,6 +32,7 @@ exec ${GUILE-@GUILE@} -L "@guilemoduledir@" -l "$0" \
(define-module (guix-download)
#:use-module (web uri)
#:use-module (web client)
+ #:use-module (guix ui)
#:use-module (guix store)
#:use-module (guix utils)
#:use-module (guix ftp-client)
@@ -44,9 +45,6 @@ exec ${GUILE-@GUILE@} -L "@guilemoduledir@" -l "$0" \
#:use-module (rnrs io ports)
#:export (guix-download))
-(define _ (cut gettext <> "guix"))
-(define N_ (cut ngettext <> <> <> "guix"))
-
(define (call-with-temporary-output-file proc)
(let* ((template (string-copy "guix-download.XXXXXX"))
(out (mkstemp! template)))
@@ -90,12 +88,6 @@ exec ${GUILE-@GUILE@} -L "@guilemoduledir@" -l "$0" \
;; Alist of default option values.
`((format . ,bytevector->nix-base32-string)))
-(define-syntax-rule (leave fmt args ...)
- "Format FMT and ARGS to the error port and exit."
- (begin
- (format (current-error-port) fmt args ...)
- (exit 1)))
-
(define (show-version)
(display "guix-download (@PACKAGE_NAME@) @PACKAGE_VERSION@\n"))