summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-30 20:55:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-17 22:37:04 +0200
commite8d2168c2711d008f6f86e223f1f3339c17c9030 (patch)
tree36f86d7b6f506a9af76374c7cd3db6d840ee5fa9 /gnu
parentc18f6368239de2c4be6560a4e0fa68a36c45374d (diff)
downloadpatches-e8d2168c2711d008f6f86e223f1f3339c17c9030.tar
patches-e8d2168c2711d008f6f86e223f1f3339c17c9030.tar.gz
gnu: Add git-annex-remote-hubic.
* gnu/packages/version-control.scm (git-annex-remote-hubic): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c24c4683c7..1edf9f8d9c 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages ssh)
#:use-module (gnu packages web)
+ #:use-module (gnu packages openstack)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -1028,3 +1029,33 @@ fetching updates) over a collection of version control repositories. It
supports a large number of version control systems: Git, Subversion,
Mercurial, Bazaar, Darcs, CVS, Fossil, and Veracity.")
(license gpl2+)))
+
+(define-public git-annex-remote-hubic
+ (package
+ (name "git-annex-remote-hubic")
+ (version "0.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Schnouki/" name "/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "196g3jkaybjx11nbr51n0cjps3wjzb145ab76y717diqvvxp5v4r"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ;; for the tests
+ ("python-six" ,python-six)))
+ (propagated-inputs
+ `(("python-dateutil" ,python-dateutil-2)
+ ("python-futures" ,python-futures)
+ ("python-rauth" ,python-rauth)
+ ("python-swiftclient" ,python-swiftclient)))
+ (home-page "https://github.com/Schnouki/git-annex-remote-hubic/")
+ (synopsis "Use hubic as a git-annex remote")
+ (description
+ "This package allows you to use your hubic account as a \"special
+repository\" with git-annex.")
+ (license gpl3+)))