summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-01-11 19:38:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-01-17 22:57:58 +0100
commit18ef998bfc91da5fd27e524e5e4b05f6374cf73a (patch)
tree69caca904d2ba6ed9b95d07998a9c44c15ed4822 /gnu
parentb153f9f0a94001baf044d257ec278613521d09b3 (diff)
downloadpatches-18ef998bfc91da5fd27e524e5e4b05f6374cf73a.tar
patches-18ef998bfc91da5fd27e524e5e4b05f6374cf73a.tar.gz
gnu: bristol: Remove SSE flags on platforms other than x86_64 and i686.
* gnu/packages/music.scm (bristol)[arguments]: Add phase "remove-sse-flags" to remove unsupported optimizations on platforms other than x86_64 and i686.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c54920986d..813893e11b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -659,6 +659,16 @@ Laurens Hammond and Don Leslie.")
(base32
"1fi2m4gmvxdi260821y09lxsimq82yv4k5bbgk3kyc3x1nyhn7vx"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-sse-flags
+ (lambda* (#:key system #:allow-other-keys)
+ (when (not (or (string-prefix? "x86_64" system)
+ (string-prefix? "i686" system)))
+ (substitute* "bristol/Makefile.in"
+ (("-msse -mfpmath=sse") "")))
+ #t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
("jack" ,jack-1)