summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:17:55 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 05:11:31 +0200
commit90cea671117f1a121821e2660702eae5cfa4b26a (patch)
tree5cbaaf906bd98a6b8a29f46d11c8d6a1d22f867a /gnu
parent67f1db3864ff26048d852adbc2bac4a67fce3879 (diff)
downloadpatches-90cea671117f1a121821e2660702eae5cfa4b26a.tar
patches-90cea671117f1a121821e2660702eae5cfa4b26a.tar.gz
gnu: openspecfun: Don't use unstable tarball.
* gnu/packages/maths.scm (openspecfun)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a71e783e49..d6e2bd815f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3182,13 +3182,13 @@ environments.")
(version "0.5.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/JuliaLang/openspecfun/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaLang/openspecfun.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1rs1bv8jq751fv9vq79890wqf9xlbjc7lvz3ighzyfczbyjcf18m"))))
+ (base32 "0pfw6l3ch7isz403llx7inxlvavqh01jh1hb9dpidi86sjjx9kfh"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no "check" target