summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-08-24 00:33:34 +0200
committerLudovic Courtès <ludo@gnu.org>2018-08-24 00:36:04 +0200
commit444488fc1b0d12190bf751b58191daea90ab243c (patch)
tree42aeeca76d59fd0aae771bf2f748ac98db920a86 /gnu
parentd32da49c76369daa58634d29560bfc9ea2fb23bd (diff)
downloadpatches-444488fc1b0d12190bf751b58191daea90ab243c.tar
patches-444488fc1b0d12190bf751b58191daea90ab243c.tar.gz
gnu: boost: Move 1.59.0 definition to boost.scm.
Fixes a regression introduced in commit 7cbf06d8c2935abfc6c688cf3f9b99e0e5393960 where the top-level code of these two modules would depend on each other, leading to "boost: unbound variable" kind of errors in some circumstances. * gnu/packages/databases.scm (boost-for-mysql): Move to... * gnu/packages/boost.scm (boost-for-mysql): ... here. Make public and add 'properties' field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/boost.scm16
-rw-r--r--gnu/packages/databases.scm14
2 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d00f96de64..cf70a29775 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -110,6 +110,22 @@ across a broad spectrum of applications.")
(license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt"
"Some components have other similar licences."))))
+(define-public boost-for-mysql
+ ;; Older version for MySQL 5.7.23.
+ (package
+ (inherit boost)
+ (version "1.59.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/boost/boost/" version "/boost_"
+ (string-map (lambda (x) (if (eq? x #\.) #\_ x)) version)
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "1jj1aai5rdmd72g90a3pd8sw9vi32zad46xv5av8fhnr48ir6ykj"))))
+ (properties '((hidden? . #t)))))
+
(define-public boost-sync
(let ((commit "c72891d9b90e2ceb466ec859f640cd012b2d8709")
(version "1.55")
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 4e64fb78b4..ecc14c259a 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -549,20 +549,6 @@ RDBMS systems (which are deep in functionality).")
;; Some parts are licensed under the Apache License
license:asl2.0))))
-(define boost-for-mysql
- (package
- (inherit boost)
- (version "1.59.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://sourceforge/boost/boost/" version "/boost_"
- (string-map (lambda (x) (if (eq? x #\.) #\_ x)) version)
- ".tar.bz2"))
- (sha256
- (base32
- "1jj1aai5rdmd72g90a3pd8sw9vi32zad46xv5av8fhnr48ir6ykj"))))))
-
;; XXX When updating, check whether boost-for-mysql is still needed.
;; It might suffice to patch ‘cmake/boost.cmake’ as done in the past.
(define-public mysql