summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-16 15:18:10 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-21 17:57:22 +0200
commite4e5a4d88fd03a088e602452c3952ab5f2201919 (patch)
treee653970fb582fec355ab5b83dbade236c17c1e63 /gnu
parent9794180d5e0c100a9d6094f8b91c7711b026c253 (diff)
downloadpatches-e4e5a4d88fd03a088e602452c3952ab5f2201919.tar
patches-e4e5a4d88fd03a088e602452c3952ab5f2201919.tar.gz
gnu: Add eXpress.
* gnu/packages/bioinformatics.scm (express): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 950f9b472f..ccfda627f3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -28,6 +28,7 @@
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages base)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages file)
#:use-module (gnu packages java)
@@ -37,6 +38,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
+ #:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages statistics)
#:use-module (gnu packages swig)
@@ -530,6 +532,51 @@ file formats including SAM/BAM, Wiggle/BigWig, BED, GFF/GTF, VCF.")
other types of unwanted sequence from high-throughput sequencing reads.")
(license license:expat)))
+(define-public express
+ (package
+ (name "express")
+ (version "1.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "http://bio.math.berkeley.edu/eXpress/downloads/express-"
+ version "/express-" version "-src.tgz"))
+ (sha256
+ (base32
+ "03rczxd0gjp2l1jxcmjfmf5j94j77zqyxa6x063zsc585nj40n0c"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;no "check" target
+ #:phases
+ (alist-cons-after
+ 'unpack 'use-shared-boost-libs-and-set-bamtools-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("set\\(Boost_USE_STATIC_LIBS ON\\)")
+ "set(Boost_USE_STATIC_LIBS OFF)")
+ (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/bamtools/include")
+ (string-append (assoc-ref inputs "bamtools") "/include/bamtools")))
+ (substitute* "src/CMakeLists.txt"
+ (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/\\.\\./bamtools/lib")
+ (string-append (assoc-ref inputs "bamtools") "/lib/bamtools")))
+ #t)
+ %standard-phases)))
+ (inputs
+ `(("boost" ,boost)
+ ("bamtools" ,bamtools)
+ ("protobuf" ,protobuf)
+ ("zlib" ,zlib)))
+ (home-page "http://bio.math.berkeley.edu/eXpress")
+ (synopsis "Streaming quantification for high-throughput genomic sequencing")
+ (description
+ "eXpress is a streaming tool for quantifying the abundances of a set of
+target sequences from sampled subsequences. Example applications include
+transcript-level RNA-Seq quantification, allele-specific/haplotype expression
+analysis (from RNA-Seq), transcription factor binding quantification in
+ChIP-Seq, and analysis of metagenomic data.")
+ (license license:artistic2.0)))
+
(define-public fastx-toolkit
(package
(name "fastx-toolkit")