summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 23:41:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-14 20:15:29 +0200
commit8b4e76249a4d1b4af5da6a8b07f4fb3c92234c07 (patch)
treecb32dfd32ac42b58c385e3f59c3e74e847be3ccc /gnu
parent5309c3a158fd7c9d8bd4bca3a34765479c237ced (diff)
downloadpatches-8b4e76249a4d1b4af5da6a8b07f4fb3c92234c07.tar
patches-8b4e76249a4d1b4af5da6a8b07f4fb3c92234c07.tar.gz
gnu: linux-libre: Set DEVPTS_MULTIPLE_INSTANCES only where needed.
* gnu/packages/linux.scm (%default-extra-linux-options): Move obsolete CONFIG_DEVPTS_MULTIPLE_INSTANCES option… (linux-libre-4.4): …here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4b2bf0e0e7..7dd675e803 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -265,9 +265,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(search-auxiliary-file file)))
(define %default-extra-linux-options
- `(;; https://lists.gnu.org/archive/html/guix-devel/2014-04/msg00039.html
- ("CONFIG_DEVPTS_MULTIPLE_INSTANCES" . #t)
- ;; Modules required for initrd:
+ `(;; Modules required for initrd:
("CONFIG_NET_9P" . m)
("CONFIG_NET_9P_VIRTIO" . m)
("CONFIG_VIRTIO_BLK" . m)
@@ -494,7 +492,13 @@ between the CDemu userspace daemon and linux kernel.")
(make-linux-libre "4.4.178"
"1lgsd760md6b32qb5ng3anfq1n754a9d0c4xnf2mjxkimncb1jpp"
'("x86_64-linux" "i686-linux")
- #:configuration-file kernel-config))
+ #:configuration-file kernel-config
+ #:extra-options
+ (append
+ `(;; https://lists.gnu.org/archive/html/guix-devel/2014-04/msg00039.html
+ ;; This option was removed upstream in version 4.7.
+ ("CONFIG_DEVPTS_MULTIPLE_INSTANCES" . #t))
+ %default-extra-linux-options)))
(define-public linux-libre-arm-generic
(make-linux-libre %linux-libre-version