summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-07 16:44:31 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:51 -0500
commit1ed6d5bc86d3c30243855c3996b473e83ac8ba03 (patch)
treeb28bb176885ae3000f5338fad342cd9efeb772da /gnu
parentb715dbac7b917e799e4d520ad6cfd99962d9fc02 (diff)
downloadpatches-1ed6d5bc86d3c30243855c3996b473e83ac8ba03.tar
patches-1ed6d5bc86d3c30243855c3996b473e83ac8ba03.tar.gz
gnu: Add XML-SAX-Base.
* gnu/packages/xml.scm (perl-xml-sax-base): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 4f8cafdb71..e298369668 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -200,6 +200,28 @@ maintain a prefix to namespace URI map, and provides a number of basic
checks.")
(license (package-license perl))))
+(define-public perl-xml-sax-base
+ (package
+ (name "perl-xml-sax-base")
+ (version "1.08")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/G/GR/GRANTM/"
+ "XML-SAX-Base-" version ".tar.gz"))
+ (sha256
+ (base32
+ "17i161rq1ngjlk0c8vdkrkkc56y1pf51k1g54y28py0micqp0qk6"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/XML-SAX-Base")
+ (synopsis "Base class for SAX Drivers and Filters")
+ (description "This module has a very simple task - to be a base class for
+PerlSAX drivers and filters. It's default behaviour is to pass the input
+directly to the output unchanged. It can be useful to use this module as a
+base class so you don't have to, for example, implement the characters()
+callback.")
+ (license (package-license perl))))
+
(define-public perl-xml-simple
(package
(name "perl-xml-simple")