summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-15 20:57:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-15 20:58:25 +0200
commit15184fb386d9b71b122e40f665d2f42bf4a13ddc (patch)
tree25d8b2d7734cea5deda6d4700309f6eb939bd883 /gnu
parent83b420912289b0f2b2caba9fc8d0eb22256722ad (diff)
downloadpatches-15184fb386d9b71b122e40f665d2f42bf4a13ddc.tar
patches-15184fb386d9b71b122e40f665d2f42bf4a13ddc.tar.gz
gnu: Add r-reportingtools.
* gnu/packages/bioconductor.scm (r-reportingtools): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3c01e2d0d4..d382ce1dfc 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1151,6 +1151,54 @@ customizable permutation tests to assess the association between genomic
region sets and other genomic features.")
(license license:artistic2.0)))
+(define-public r-reportingtools
+ (package
+ (name "r-reportingtools")
+ (version "2.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ReportingTools" version))
+ (sha256
+ (base32
+ "16ska7mlacka0xi8x2icy8v42vaxccb3a1x73szmfvcrwr592qsc"))))
+ (properties
+ `((upstream-name . "ReportingTools")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotate" ,r-annotate)
+ ("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-category" ,r-category)
+ ("r-deseq2" ,r-deseq2)
+ ("r-edger" ,r-edger)
+ ("r-ggbio" ,r-ggbio)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gostats" ,r-gostats)
+ ("r-gseabase" ,r-gseabase)
+ ("r-hwriter" ,r-hwriter)
+ ("r-iranges" ,r-iranges)
+ ("r-knitr" ,r-knitr)
+ ("r-lattice" ,r-lattice)
+ ("r-limma" ,r-limma)
+ ("r-pfam-db" ,r-pfam-db)
+ ("r-r-utils" ,r-r-utils)
+ ("r-xml" ,r-xml)))
+ (home-page "https://bioconductor.org/packages/ReportingTools/")
+ (synopsis "Tools for making reports in various formats")
+ (description
+ "The ReportingTools package enables users to easily display reports of
+analysis results generated from sources such as microarray and sequencing
+data. The package allows users to create HTML pages that may be viewed on a
+web browser, or in other formats. Users can generate tables with sortable and
+filterable columns, make and display plots, and link table entries to other
+data sources such as NCBI or larger plots within the HTML page. Using the
+package, users can also produce a table of contents page to link various
+reports together for a particular project that can be viewed in a web
+browser.")
+ (license license:artistic2.0)))
+
(define-public r-geneplotter
(package
(name "r-geneplotter")