summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-13 19:45:02 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-13 19:45:02 +0200
commit13d25c546010ded6a275f167497386e6e253b54e (patch)
tree37b8a7b09424b4ef9bf109532ae708461e4b930e /gnu
parent94cbae1b8901f9fdfdfb89d0880619727654ac65 (diff)
downloadpatches-13d25c546010ded6a275f167497386e6e253b54e.tar
patches-13d25c546010ded6a275f167497386e6e253b54e.tar.gz
gnu: python2-backports-shutil-get-terminal-size: Fix test failure.
* gnu/packages/python-xyz.scm (python2-backports-shutil-get-terminal-size)[arguments]: In the check phase, set PYTHONPATH before running the tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ba00670459..e5f7808baf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7196,6 +7196,8 @@ Python 2 and Python 3.")
(modify-phases %standard-phases
(replace 'check
(lambda _
+ (setenv "PYTHONPATH" (string-append "./build/lib:"
+ (getenv "PYTHONPATH")))
(invoke "py.test" "-v"))))))
(native-inputs
`(("python2-pytest" ,python2-pytest)))