summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:44:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:44:58 +0200
commited1ff94fe23dbe28ce39fa9c7be5bec6c1ae29dc (patch)
tree2b3ba73016d73d17659581980c8f18dd995490c8 /gnu
parent0dcb8e83f4c96cffa790b46768496988b390937a (diff)
downloadpatches-ed1ff94fe23dbe28ce39fa9c7be5bec6c1ae29dc.tar
patches-ed1ff94fe23dbe28ce39fa9c7be5bec6c1ae29dc.tar.gz
gnu: emacs-auto-complete: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-auto-complete)[source]: Download using git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 415814baa2..7d36c6dcbf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8135,13 +8135,14 @@ by zenburn, sinburn and similar themes, but slowly diverging from them.")
(version "1.5.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/auto-complete/"
- "auto-complete/archive/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/auto-complete/auto-complete.git")
+ (commit (string-append "v" version))))
(sha256
(base32
- "1jvq4lj00hwml75lpmlciazy8f3bbg13gffsfnl835p4qd8l7yqv"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "04i9b11iksg6acn885wl3qgi5xpsm3yszlqmd2x21yhprndlz7gb"))
+ (file-name (git-file-name name version))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-popup" ,emacs-popup)))