summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-15 10:21:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-15 13:05:22 +0100
commitc2a1fe4ad2dd5eed7eb7fd4f0b68c58a1d2ae7ee (patch)
tree5290bc07a41347145435826ea7afe19fb8952116 /gnu
parent4e9242aaeb5e69049aedc2972ea3b2dbfe2d797e (diff)
downloadpatches-c2a1fe4ad2dd5eed7eb7fd4f0b68c58a1d2ae7ee.tar
patches-c2a1fe4ad2dd5eed7eb7fd4f0b68c58a1d2ae7ee.tar.gz
gnu: Add texlive-fonts-lm.
* gnu/packages/tex.scm (texlive-fonts-lm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e61673854c..0819008e8f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -767,6 +767,43 @@ originals.")
;; With font exception
(license license:gpl2+)))
+(define-public texlive-fonts-lm
+ (package
+ (name "texlive-fonts-lm")
+ (version "2.004")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.gust.org.pl/projects/e-foundry/"
+ "latin-modern/download/lm" version "bas.zip"))
+ (sha256
+ (base32
+ "0z2s253y751m2ci5aw8nq0sf2kyg9hpimv2gyixkch9d07m2b9wp"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((root (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/")))
+ (mkdir-p root)
+ (with-directory-excursion root
+ (invoke (string-append (assoc-ref %build-inputs "unzip")
+ "/bin/unzip")
+ (assoc-ref %build-inputs "source")))
+ #t))))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (home-page "http://www.gust.org.pl/projects/e-foundry/latin-modern/")
+ (synopsis "Latin Modern family of fonts")
+ (description "The Latin Modern fonts are derived from the famous Computer
+Modern fonts designed by Donald E. Knuth and described in Volume E of his
+Computers & Typesetting series.")
+ ;; The GUST font license (GFL) is legally identical to the LaTeX Project
+ ;; Public License (LPPL), version 1.3c or later, but comes with an
+ ;; additional but not legally binding clause.
+ (license license:lppl1.3c+)))
+
(define-public texlive-fonts-knuth-lib
(package
(name "texlive-fonts-knuth-lib")