summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-01 11:31:29 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-02 14:26:14 +0200
commit132b4c8c235e599a28604facce7ecee01b4a446e (patch)
tree42b6261b79918ab1f552369af63410c1cbba5d93 /gnu
parent52eca736f6b8fedb7d0cc4dd281059f672d88734 (diff)
downloadpatches-132b4c8c235e599a28604facce7ecee01b4a446e.tar
patches-132b4c8c235e599a28604facce7ecee01b4a446e.tar.gz
gnu: ncbi-vdb: Use "i386" instead of "i686" in directory name.
* gnu/packages/bioinformatics.scm (ncbi-vdb)[arguments]: Copy libraries from "linux/gcc/i386" directory instead of "linux/gcc/i686" when building on i686.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2355cbf9cf..f66ea26b2a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1451,11 +1451,16 @@ simultaneously.")
(assoc-ref inputs "hdf5"))))))
(alist-cons-after
'install 'install-interfaces
- (lambda* (#:key system outputs #:allow-other-keys)
- ;; Install interface libraries
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Install interface libraries. On i686 the interface libraries
+ ;; are installed to "linux/gcc/i386", so we need to use the Linux
+ ;; architecture name ("i386") instead of the target system prefix
+ ;; ("i686").
(mkdir (string-append (assoc-ref outputs "out") "/ilib"))
(copy-recursively (string-append "build/ncbi-vdb/linux/gcc/"
- (car (string-split system #\-))
+ ,(system->linux-architecture
+ (or (%current-target-system)
+ (%current-system)))
"/rel/ilib")
(string-append (assoc-ref outputs "out")
"/ilib"))