summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-02 23:59:56 -0500
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-26 12:59:32 +0100
commit05a852d8dda891dfd7f7e5d3f8c475ce378b1396 (patch)
tree3b04d3000cc0e4ace694f14d84f7d8757078820b /gnu
parent0c7b63e065d7e3c167fef2473e1158e9eff70dc5 (diff)
downloadpatches-05a852d8dda891dfd7f7e5d3f8c475ce378b1396.tar
patches-05a852d8dda891dfd7f7e5d3f8c475ce378b1396.tar.gz
gnu: commencement: glibc-intermediate: Build fixes for the Hurd.
* gnu/packages/commencement.scm (glibc-intermediate): Configure with --disable-werror, update pthreads workaround.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 7e3109fca7..446e3260ae 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3230,7 +3230,9 @@ the bootstrap environment."
((#:configure-flags flags)
`(append (list ,(string-append "--host=" (boot-triplet))
,(string-append "--build="
- (nix-system->gnu-triplet)))
+ (nix-system->gnu-triplet))
+ ,(if (hurd-system?) "--disable-werror"
+ ""))
,flags))
((#:phases phases)
`(modify-phases ,phases
@@ -3241,13 +3243,14 @@ the bootstrap environment."
(unsetenv "CPATH")
;; Tell 'libpthread' where to find 'libihash' on Hurd systems.
- ,@(if (hurd-triplet? (%current-system))
- `((substitute* "libpthread/Makefile"
- (("LDLIBS-pthread.so =.*")
- (string-append "LDLIBS-pthread.so = "
- (assoc-ref %build-inputs "kernel-headers")
- "/lib/libihash.a\n"))))
- '())
+ ,@(if (hurd-system?)
+ '((substitute* '("sysdeps/mach/Makefile"
+ "sysdeps/mach/hurd/Makefile")
+ (("LDLIBS-pthread.so =.*")
+ (string-append "LDLIBS-pthread.so = "
+ (assoc-ref %build-inputs "kernel-headers")
+ "/lib/libihash.a\n"))))
+ '())
;; 'rpcgen' needs native libc headers to be built.
(substitute* "sunrpc/Makefile"
@@ -3268,7 +3271,7 @@ the bootstrap environment."
,@(%boot1-inputs)
;; A native MiG is needed to build Glibc on Hurd.
- ,@(if (hurd-triplet? (%current-system))
+ ,@(if (hurd-system?)
`(("mig" ,mig-boot0))
'())