summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:03:37 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitcb2119e4f5da8bb34ea865504250759138bf38ba (patch)
treecc377c0747c8d2e3ee1642799365514669d351ca /gnu
parenta195cd795f2d09f167ce68f3a75e9dee6845ae35 (diff)
downloadpatches-cb2119e4f5da8bb34ea865504250759138bf38ba.tar
patches-cb2119e4f5da8bb34ea865504250759138bf38ba.tar.gz
gnu: Add ghc-doctest.
* gnu/packages/haskell.scm (ghc-doctest): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c43bbdcd86..d7e07efcdf 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2174,4 +2174,39 @@ command line options in Haskell.")
available in later versions of base to a wider (older) range of compilers.")
(license bsd-3)))
+(define-public ghc-doctest
+ (package
+ (name "ghc-doctest")
+ (version "0.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/doctest/doctest-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1jbyhzbi2hfrfg7vbkpj6vriaap8cn99nnmzwcfscwaijz09jyrm"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: missing test framework
+ (propagated-inputs
+ `(("ghc-syb" ,ghc-syb)
+ ("ghc-paths" ,ghc-paths)))
+ (inputs
+ `(("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-stringbuilder" ,ghc-stringbuilder)
+ ("ghc-silently" ,ghc-silently)
+ ("ghc-setenv" ,ghc-setenv)))
+ (home-page
+ "https://github.com/sol/doctest#readme")
+ (synopsis "Test interactive Haskell examples")
+ (description "The doctest program checks examples in source code comments.
+It is modeled after doctest for Python, see
+@uref{http://docs.python.org/library/doctest.html, the Doctest website}.")
+ (license expat)))
+
;;; haskell.scm ends here