summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-14 23:20:28 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitb38c1627eca82786c8a81ab74d2d5be3891ac5e5 (patch)
tree5c6718759665ef18a441db832047f54ef21b9486 /gnu
parent13244b2438d167e7818b6e4e472ac9c00b0eb911 (diff)
downloadpatches-b38c1627eca82786c8a81ab74d2d5be3891ac5e5.tar
patches-b38c1627eca82786c8a81ab74d2d5be3891ac5e5.tar.gz
gnu: ghc-http: Update to 4000.2.20.
* gnu/packages/haskell.scm (ghc-http): Update to 4000.2.20. Add input old-time, required in new GHC 7.10.2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c9a1020fb2..9cd223a06d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1205,7 +1205,7 @@ package into this package.")
(define-public ghc-http
(package
(name "ghc-http")
- (version "4000.2.19")
+ (version "4000.2.20")
(outputs '("out" "doc"))
(source
(origin
@@ -1216,12 +1216,13 @@ package into this package.")
".tar.gz"))
(sha256
(base32
- "1yzm8gimh8g0wwbixcbxg60v4l3vgi63w9v55ms0x9qnm6vrgysz"))))
+ "0nyqdxr5ls2dxkf4a1f3x15xzwdm46ppn99nkcbhswlr6s3cq1s4"))))
(build-system haskell-build-system)
(inputs
`(("ghc-hunit" ,ghc-hunit)))
(propagated-inputs
- `(("ghc-parsec" ,ghc-parsec)
+ `(("ghc-old-time" ,ghc-old-time)
+ ("ghc-parsec" ,ghc-parsec)
("ghc-mtl" ,ghc-mtl)
("ghc-network" ,ghc-network)
("ghc-network-uri" ,ghc-network-uri)))