summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 19:12:09 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commita59ab2477a01d007dc3ef0e4d6e21edcccce1c4a (patch)
tree0868b14f09ff93ea8505a2fa7b71e17d1a58f72e /gnu
parent0e03d76a5128579ea8e08a51b47a6fe16ae71cf3 (diff)
downloadpatches-a59ab2477a01d007dc3ef0e4d6e21edcccce1c4a.tar
patches-a59ab2477a01d007dc3ef0e4d6e21edcccce1c4a.tar.gz
gnu: ghc-mtl: Update to 2.2.1.
* gnu/packages/haskell.scm (ghc-mtl): Update to 2.2.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index af80e0c9a1..385c295737 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -462,7 +462,7 @@ installation of Haskell libraries and programs.")
(define-public ghc-mtl
(package
(name "ghc-mtl")
- (version "2.1.3.1")
+ (version "2.2.1")
(outputs '("out" "doc"))
(source
(origin
@@ -473,18 +473,17 @@ installation of Haskell libraries and programs.")
".tar.gz"))
(sha256
(base32
- "1xpn2wjmqbh2cg1yssc6749xpgcqlrrg4iilwqgkcjgvaxlpdbvp"))))
+ "1icdbj2rshzn0m1zz5wa7v3xvkf6qw811p4s7jgqwvx1ydwrvrfa"))))
(build-system haskell-build-system)
(home-page "http://github.com/ekmett/mtl")
(synopsis
"Monad classes, using functional dependencies")
- (description
- "Monad classes using functional dependencies, with instances
-for various monad transformers, inspired by the paper
-'Functional Programming with Overloading and Higher-Order Polymorphism',
-by Mark P Jones, in 'Advanced School of Functional Programming', 1995
-http://web.cecs.pdx.edu/~mpj/pubs/springschool.html.")
- (license bsd-3)))
+ (description "Monad classes using functional dependencies, with instances
+for various monad transformers, inspired by the paper 'Functional Programming
+with Overloading and Higher-Order Polymorphism', by Mark P Jones, in 'Advanced
+School of Functional Programming', 1995. See
+@uref{http://web.cecs.pdx.edu/~mpj/pubs/springschool.html, the paper}.")
+ (license bsd-3)))
(define-public ghc-paths
(package