summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:00:40 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commita45a15df50e880b8e9eeaac75394838e632a46e1 (patch)
treeed44cd511f46f3acfb95ff98d0fd3da812c7a104 /gnu
parente2fcaff2ef3804cc9e4b29e9dc99e896439c2f45 (diff)
downloadpatches-a45a15df50e880b8e9eeaac75394838e632a46e1.tar
patches-a45a15df50e880b8e9eeaac75394838e632a46e1.tar.gz
gnu: Add ghc-setenv.
* gnu/packages/haskell.scm (ghc-setenv): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9e9f18c058..b5518b5e24 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -20,7 +20,7 @@
(define-module (gnu packages haskell)
#:use-module (ice-9 regex)
- #:use-module ((guix licenses) #:select (bsd-3 lgpl2.1))
+ #:use-module ((guix licenses) #:select (bsd-3 lgpl2.1 expat))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
@@ -583,6 +583,27 @@ for encoding UTF8 strings to Word8 lists and back, and for reading and writing
UTF8 without truncation.")
(license bsd-3)))
+(define-public ghc-setenv
+ (package
+ (name "ghc-setenv")
+ (version "0.1.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/setenv/setenv-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0cnbgrvb9byyahb37zlqrj05rj25v190crgcw8wmlgf0mwwxyn73"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/setenv")
+ (synopsis "Library for setting environment variables")
+ (description "This package provides a Haskell library for setting
+environment variables.")
+ (license expat)))
+
(define-public ghc-x11
(package
(name "ghc-x11")