summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:14:40 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit49465144373fad97afb5e04529d0f66505c1f2bc (patch)
tree662c2c4cbd4faba89ccd52c59bcd952fc3e402ef /gnu
parent10de4306d623cb01475653190e8aa8eafee3367b (diff)
downloadpatches-49465144373fad97afb5e04529d0f66505c1f2bc.tar
patches-49465144373fad97afb5e04529d0f66505c1f2bc.tar.gz
gnu: Add ghc-fingertree.
* gnu/packages/haskell.scm (ghc-fingertree): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b11b0de624..fb2339b852 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1847,4 +1847,29 @@ over threads in Haskell, in which @code{Async a} is a concurrent thread that
will eventually deliver a value of type @code{a}.")
(license bsd-3)))
+(define-public ghc-fingertree
+ (package
+ (name "ghc-fingertree")
+ (version "0.1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/fingertree/fingertree-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1w6x3kp3by5yjmam6wlrf9vap5l5rrqaip0djbrdp0fpf2imn30n"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
+ (home-page "http://hackage.haskell.org/package/fingertree")
+ (synopsis "Generic finger-tree structure")
+ (description "This library provides finger trees, a general sequence
+representation with arbitrary annotations, for use as a base for
+implementations of various collection types. It includes examples, as
+described in section 4 of Ralf Hinze and Ross Paterson, \"Finger trees: a
+simple general-purpose data structure\".")
+ (license bsd-3)))
+
;;; haskell.scm ends here