summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-15 19:46:40 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-15 19:46:40 +0200
commit5ba856aba340d85744cedcfeeb34319cb778de11 (patch)
treeb25845b37f75b46ef73c426fbea20e1b79915cd2 /gnu
parentcdc07e6854f26f7034f424822f681f2fb578247d (diff)
downloadpatches-5ba856aba340d85744cedcfeeb34319cb778de11.tar
patches-5ba856aba340d85744cedcfeeb34319cb778de11.tar.gz
gnu: Adjust CPATH overrides to work with GCC 7 search paths.
* gnu/packages/education.scm (gcompris)[arguments]: Preserve original CPATH, if any. * gnu/packages/games.scm (ltris, prboom-plus, abbaye, red-eclipse, btanks, 4dtris, edgar)[arguments]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/education.scm3
-rw-r--r--gnu/packages/games.scm21
2 files changed, 16 insertions, 8 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index f3d8907583..493a97fdf8 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -83,7 +83,8 @@
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append (assoc-ref inputs "sdl-mixer")
- "/include/SDL"))
+ "/include/SDL:"
+ (or (getenv "CPATH") "")))
#t)))))
(inputs
`(("gtk+" ,gtk+-2)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6e54abc5d0..9ada6438e1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -906,7 +906,8 @@ Chess). It is similar to standard chess but this variant is far more complicate
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append (assoc-ref inputs "sdl-union")
- "/include/SDL"))
+ "/include/SDL:"
+ (or (getenv "CPATH") "")))
#t)))))
(inputs
`(("sdl-union" ,(sdl-union (list sdl sdl-mixer)))))
@@ -1118,7 +1119,8 @@ Every puzzle has a complete solution, although there may be more than one.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append (assoc-ref inputs "sdl-union")
- "/include/SDL"))
+ "/include/SDL:"
+ (or (getenv "CPATH") "")))
#t)))))
(inputs
`(("fluidsynth" ,fluidsynth)
@@ -1350,7 +1352,8 @@ can be explored and changed freely.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append (assoc-ref inputs "sdl-union")
- "/include/SDL"))))
+ "/include/SDL:"
+ (or (getenv "CPATH") "")))))
(add-after 'patch-source-shebangs 'patch-makefile
(lambda* (#:key outputs #:allow-other-keys)
;; Replace /usr with package output directory.
@@ -2992,7 +2995,8 @@ http://lavachat.symlynx.com/unix/")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append (assoc-ref inputs "sdl-union")
- "/include/SDL2"))
+ "/include/SDL2:"
+ (or (getenv "CPATH") "")))
#t))
(add-after 'install 'copy-data
(lambda* (#:key outputs #:allow-other-keys)
@@ -6398,7 +6402,8 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append (assoc-ref inputs "sdl")
- "/include/SDL"))
+ "/include/SDL:"
+ (or (getenv "CPATH") "")))
#t))
(add-after 'unpack 'fix-compilation-errors
(lambda _
@@ -6517,7 +6522,8 @@ affected by the gravity of the planets.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append (assoc-ref inputs "sdl")
- "/include/SDL"))
+ "/include/SDL:"
+ (or (getenv "CPATH") "")))
#t)))))
(inputs
`(("fontconfig" ,fontconfig)
@@ -6636,7 +6642,8 @@ the desired spell.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append (assoc-ref inputs "sdl2-union")
- "/include/SDL2"))
+ "/include/SDL2:"
+ (or (getenv "CPATH") "")))
#t)))))
(inputs
`(("sdl2-union" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))