aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 20:32:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 20:32:29 +0100
commit57be690d912ad9e1683f80d4de2e1076ae27948d (patch)
tree491439e6e06d4d058a489a8e487635e0c47f825c /gnu
parentc8f02c1dcb36eca7ef0fd58239dcbf1d4c67f63c (diff)
downloadpatches-57be690d912ad9e1683f80d4de2e1076ae27948d.tar
patches-57be690d912ad9e1683f80d4de2e1076ae27948d.tar.gz
gnu: hisat2: Use versioned source URL.
* gnu/packages/bioinformatics.scm (hisat2)[source]: Use versioned URL.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fb147a79c6..eae5236cad 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3006,16 +3006,11 @@ particular, reads spanning multiple exons.")
(source
(origin
(method url-fetch)
- ;; FIXME: a better source URL is
- ;; (string-append "ftp://ftp.ccb.jhu.edu/pub/infphilo/hisat2"
- ;; "/downloads/hisat2-" version "-source.zip")
- ;; with hash "0lywnr8kijwsc2aw10dwxic0n0yvip6fl3rjlvc8zzwahamy4x7g"
- ;; but it is currently unavailable.
- (uri "https://github.com/infphilo/hisat2/archive/cba6e8cb.tar.gz")
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (string-append "ftp://ftp.ccb.jhu.edu/pub/infphilo/hisat2"
+ "/downloads/hisat2-" version "-source.zip"))
(sha256
(base32
- "1mf2hdsyv7cd97xm9mp9a4qws02yrj95y6w6f6cdwnq0klp81r50"))))
+ "0lywnr8kijwsc2aw10dwxic0n0yvip6fl3rjlvc8zzwahamy4x7g"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target