summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-03 17:41:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-03 17:42:18 +0200
commitb50c966087b908e046da06e330c01e6d7a1ae9ca (patch)
tree46f72fdd0fa98869e015d95219c5905b70501d13 /gnu
parent5622628fd1a6e849b9ccebc37a944d892acb4c51 (diff)
downloadpatches-b50c966087b908e046da06e330c01e6d7a1ae9ca.tar
patches-b50c966087b908e046da06e330c01e6d7a1ae9ca.tar.gz
gnu: Add r-arrmdata.
* gnu/packages/bioconductor.scm (r-arrmdata): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d033258d17..b949b894c5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -778,6 +778,30 @@ datasets which are derived from the Allen Brain Atlas:
All datasets are restricted to protein coding genes.")
(license license:gpl2+)))
+(define-public r-arrmdata
+ (package
+ (name "r-arrmdata")
+ (version "1.18.0")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/experiment/" instead of "bioc/".
+ (uri (string-append "https://www.bioconductor.org/packages/"
+ "release/data/experiment/src/contrib/"
+ "ARRmData_" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r1y3zn7ly4k3ngx55vfavn9s6aidbddlv2fbmj7hj3hvpslmyly"))))
+ (properties
+ `((upstream-name . "ARRmData")))
+ (build-system r-build-system)
+ (home-page "https://www.bioconductor.org/packages/ARRmData/")
+ (synopsis "Example dataset for normalization of Illumina 450k methylation data")
+ (description
+ "This package provides raw beta values from 36 samples across 3 groups
+from Illumina 450k methylation arrays.")
+ (license license:artistic2.0)))
+
(define-public r-hsmmsinglecell
(package
(name "r-hsmmsinglecell")