summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-04 13:23:08 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-04 17:47:01 +0200
commita7ad4505b7a09f32e2727a333e11716739efb713 (patch)
treee6b2aa4a46b0e365a3359fe7dca5f9b5925f4f77 /gnu
parent660e00507e308cdfe0bab681d95dc2cc07000b80 (diff)
downloadpatches-a7ad4505b7a09f32e2727a333e11716739efb713.tar
patches-a7ad4505b7a09f32e2727a333e11716739efb713.tar.gz
build: Always ship the (gnu installer …) modules.
Fixes <https://bugs.gnu.org/35138>. Reported by Jonathan Brielmaier <jonathan.brielmaier@web.de>. * gnu/local.mk (INSTALLER_MODULES): New variable. (GNU_SYSTEM_MODULES, MODULES_NOT_COMPILED): Append $(INSTALLER_MODULES) conditionally.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 586be80eb7..ecb7f9c8d0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -584,9 +584,7 @@ GNU_SYSTEM_MODULES = \
%D%/tests/virtualization.scm \
%D%/tests/web.scm
-if ENABLE_INSTALLER
-
-GNU_SYSTEM_MODULES += \
+INSTALLER_MODULES = \
%D%/installer.scm \
%D%/installer/connman.scm \
%D%/installer/final.scm \
@@ -618,13 +616,19 @@ GNU_SYSTEM_MODULES += \
%D%/installer/newt/welcome.scm \
%D%/installer/newt/wifi.scm
+# Always ship the installer modules but compile them only when
+# ENABLE_INSTALLER is true.
+if ENABLE_INSTALLER
+GNU_SYSTEM_MODULES += $(INSTALLER_MODULES)
+elif !ENABLE_INSTALLER
+MODULES_NOT_COMPILED += $(INSTALLER_MODULES)
+endif
+
installerdir = $(guilemoduledir)/%D%/installer
dist_installer_DATA = \
%D%/installer/aux-files/logo.txt \
%D%/installer/aux-files/SUPPORTED
-endif ENABLE_INSTALLER
-
# Modules that do not need to be compiled.
MODULES_NOT_COMPILED += \
%D%/build/shepherd.scm \