summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 19:39:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-27 12:46:40 +0200
commit8448e6bfcfbdedc8fd0e6c72a17cc3b0f469e182 (patch)
tree02192a0df540eb0af15b8da2da53a854afdd6923 /gnu
parent3929f46c99fcb7d633e340666ed9f285d7b27a0c (diff)
downloadpatches-8448e6bfcfbdedc8fd0e6c72a17cc3b0f469e182.tar
patches-8448e6bfcfbdedc8fd0e6c72a17cc3b0f469e182.tar.gz
gnu: dlib: Return #t from all phases.
* gnu/packages/machine-learning.scm (dlib)[arguments]: Substitute INVOKE for SYSTEM*. Return #t rather than undefined from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index d1025c23d6..d20e685231 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -668,8 +668,9 @@ and a QP solver.")
;; No test target, so we build and run the unit tests here.
(let ((test-dir (string-append "../dlib-" ,version "/dlib/test")))
(with-directory-excursion test-dir
- (and (zero? (system* "make" "-j" (number->string (parallel-job-count))))
- (zero? (system* "./dtest" "--runall")))))))
+ (invoke "make" "-j" (number->string (parallel-job-count)))
+ (invoke "./dtest" "--runall"))
+ #t)))
(add-after 'install 'delete-static-library
(lambda* (#:key outputs #:allow-other-keys)
(delete-file (string-append (assoc-ref outputs "out")