summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2016-01-11 13:28:05 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-01-14 09:12:23 -0500
commit67c52bb3e7fd0b50dc201739049a82a14175f3ee (patch)
tree693a87c4d950a6ca47685134970855a237de1722 /gnu
parent210bf49754f397e229a4e1a81f8d16a52dcdef7a (diff)
downloadpatches-67c52bb3e7fd0b50dc201739049a82a14175f3ee.tar
patches-67c52bb3e7fd0b50dc201739049a82a14175f3ee.tar.gz
gnu: Add python-websocket-client.
* gnu/packages/python.scm (python-websocket-client): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4081362f2f..6b0721b496 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6679,3 +6679,30 @@ tables.")
(define-public python2-texttable
(package-with-python2 python-texttable))
+
+(define-public python-websocket-client
+ (package
+ (name "python-websocket-client")
+ (version "0.34.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/w"
+ "/websocket-client/websocket_client-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1prdx6d49f1cff17kzj15bnz09palfdgc1m5dkq9jd4mr90n4ak8"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-six" ,python-six))) ; for tests
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/liris/websocket-client")
+ (synopsis "WebSocket client for Python")
+ (description "The Websocket-client module provides the low level APIs for
+WebSocket usage in Python programs.")
+ (license lgpl2.1+)))
+
+(define-public python2-websocket-client
+ (package-with-python2 python-websocket-client))