summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2016-06-17 10:41:50 +0200
committerLeo Famulari <leo@famulari.name>2016-09-27 13:37:46 -0400
commit32f70e1f86141ed30f1026ea0cf8a4bd377004b0 (patch)
tree173c2e403230ae0499501682a26b84cc819cebb7 /gnu
parent3973e137f083229c819bcfa6bb8c08ab2d5e50ff (diff)
downloadpatches-32f70e1f86141ed30f1026ea0cf8a4bd377004b0.tar
patches-32f70e1f86141ed30f1026ea0cf8a4bd377004b0.tar.gz
gnu: Add gctp.
* gnu/packages/maths.scm (gctp): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1e7f4ca5b0..0401cd3bd5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -418,6 +418,32 @@ plotting engine by third-party applications like Octave.")
(license (license:fsf-free
"http://gnuplot.cvs.sourceforge.net/gnuplot/gnuplot/Copyright")))))
+(define-public gctp
+ (package
+ (name "gctp")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/OkoSanto/GCTP/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0l9aqnqynh9laicn5dxf3rsb1n14xiks79wbyqccirzmjqd1c1x4"))))
+ (native-inputs
+ `(("fortran" ,gfortran)))
+ (build-system gnu-build-system)
+ (synopsis "General Cartographic Transformation Package (GCTP)")
+ (description
+ "The General Cartographic Transformation Package (GCTP) is a system of
+software routines designed to permit the transformation of coordinate pairs
+from one map projection to another. The GCTP is the standard computer
+software used by the National Mapping Division for map projection
+computations.")
+ (home-page "https://github.com/OkoSanto/GCTP")
+ (license 'license:public-domain))) ; https://www2.usgs.gov/laws/info_policies.html
+
(define-public hdf5
(package
(name "hdf5")