summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-06-12 21:06:50 -0400
committerDavid Thompson <davet@gnu.org>2015-06-15 20:27:38 -0400
commit2206e94892f58e695ed417240f189b1f8c3048d7 (patch)
treeab0cf9dcf210946868a993c42ab37b856a9217fc /gnu
parentafbbdf7752c561fc3688d0f2d69977fde11d0429 (diff)
downloadpatches-2206e94892f58e695ed417240f189b1f8c3048d7.tar
patches-2206e94892f58e695ed417240f189b1f8c3048d7.tar.gz
gnu: Add ruby-minitest.
* gnu/packages/ruby.scm (ruby-minitest): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 44ca0dc63a..d090d35a38 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -466,6 +466,34 @@ using Net::HTTP, supporting reconnection and retry according to RFC 2616.")
(home-page "https://github.com/drbrain/net-http-persistent")
(license license:expat)))
+(define-public ruby-minitest
+ (package
+ (name "ruby-minitest")
+ (version "5.7.0")
+ (source (origin
+ (method git-fetch)
+ ;; No release tarballs nor git tags. This is the commit
+ ;; corresponding to the addition of the release notes to
+ ;; History.rdoc.
+ (uri (git-reference
+ (url "https://github.com/seattlerb/minitest.git")
+ (commit "e975248")))
+ (sha256
+ (base32
+ "09xjiahk7q8hid1i39ahrmghaslpj9n36zna72i3ah7kf1bh2l01"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'build ; no gemspec
+ (lambda _ (zero? (system* "rake" "gem")))))))
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)))
+ (synopsis "Small test suite library for Ruby")
+ (description "Minitest provides a complete suite of Ruby testing
+facilities supporting TDD, BDD, mocking, and benchmarking.")
+ (home-page "https://github.com/seattlerb/minitest")
+ (license license:expat)))
+
(define-public ruby-daemons
(package
(name "ruby-daemons")