summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-22 01:26:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-22 02:49:12 +0100
commit0f0642423c8cf799bfe8b5a095b57f7fbddeaf19 (patch)
treecde5feea42dba60540ef01b69c0fb174f007dd03 /gnu
parent0f6d5115aab55deb336baf1a5866f16d4252a472 (diff)
downloadpatches-0f0642423c8cf799bfe8b5a095b57f7fbddeaf19.tar
patches-0f0642423c8cf799bfe8b5a095b57f7fbddeaf19.tar.gz
gnu: python2-empy: Run tests.
* gnu/packages/python-xyz.scm (python2-empy)[arguments]: Re-enable tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f093a6601c..ed97ec5e13 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1166,7 +1166,11 @@ commands.")
(license license:lgpl2.1+)))
(define-public python2-empy
- (package-with-python2 python-empy))
+ (let ((base (package-with-python2 (strip-python2-variant python-empy))))
+ (package
+ (inherit base)
+ (arguments `(,@(package-arguments base)
+ #:tests? #t)))))
(define-public python2-element-tree
(package