summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-10-12 13:45:35 -0500
committerAlex Griffin <a@ajgrf.com>2019-10-29 21:15:07 -0500
commitd392f8039a943b070369ecde44cfed8435ac12ad (patch)
treefbed90aa1ee26d90fd95b819f2aa75afac4aac46 /gnu
parent9ad9ec2e6192017ccac59330c0056c370c079603 (diff)
downloadpatches-d392f8039a943b070369ecde44cfed8435ac12ad.tar
patches-d392f8039a943b070369ecde44cfed8435ac12ad.tar.gz
gnu: Add ghc-unagi-chan.
* gnu/packages/haskell-xyz.scm (ghc-unagi-chan): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e134641de4..217c78a08c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10628,6 +10628,37 @@ processes. It wraps around the @code{process} library, and intends to improve
upon it.")
(license license:expat)))
+(define-public ghc-unagi-chan
+ (package
+ (name "ghc-unagi-chan")
+ (version "0.4.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/unagi-chan"
+ "/unagi-chan-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lnl5n4jnjmm4chp461glcwkrrw63rjz3fvprwxcy3lkpbkrqvgn"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-atomic-primops" ,ghc-atomic-primops)
+ ("ghc-primitive" ,ghc-primitive)))
+ (arguments
+ `(#:tests? #f ; FIXME: Tests expect primitive 0.7
+ #:cabal-revision
+ ("1"
+ "09pqi867wskwgc5lpn197f895mbn1174ydgllvcppcsmrz2b6yr6")))
+ (home-page "http://hackage.haskell.org/package/unagi-chan")
+ (synopsis "Fast concurrent queues with a Chan-like API, and more")
+ (description
+ "This library provides implementations of concurrent FIFO queues (for
+both general boxed and primitive unboxed values) that are fast, perform well
+under contention, and offer a Chan-like interface. The library may be of
+limited usefulness outside of x86 architectures where the fetch-and-add
+instruction is not available.")
+ (license license:bsd-3)))
+
(define-public ghc-unbounded-delays
(package
(name "ghc-unbounded-delays")