summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-05 19:32:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 20:03:07 +0200
commitdc66835226858236c12c498cc9de0e98c8c86e18 (patch)
tree6a521213015896fd5eb4c76b1802e539fc628c78 /gnu
parent45c156bf812e227b07e94b0420d41ed57ae10220 (diff)
downloadpatches-dc66835226858236c12c498cc9de0e98c8c86e18.tar
patches-dc66835226858236c12c498cc9de0e98c8c86e18.tar.gz
gnu: Add r-ucminf.
* gnu/packages/cran.scm (r-ucminf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4cf7d6295e..f64b48da5f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1981,6 +1981,30 @@ can be computed between character vectors while taking proper care of encoding
or between integer vectors representing generic sequences.")
(license license:gpl3+)))
+(define-public r-ucminf
+ (package
+ (name "r-ucminf")
+ (version "1.1-4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ucminf" version))
+ (sha256
+ (base32
+ "01vggwg1w71k98qs6fhb0x1843vi322mf4g3hbclks94kcpkisx2"))))
+ (build-system r-build-system)
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/ucminf/")
+ (synopsis "General-purpose unconstrained non-linear optimization")
+ (description
+ "This package provides an implementation of an algorithm for
+general-purpose unconstrained non-linear optimization. The algorithm is of
+quasi-Newton type with BFGS updating of the inverse Hessian and soft line
+search with a trust region type monitoring of the input to the line search
+algorithm. The interface of @code{ucminf} is designed for easy interchange
+with the package @code{optim}.")
+ (license license:gpl2+)))
+
(define-public r-jomo
(package
(name "r-jomo")